FAQ

  • How can I upgrade ONLY the JasperReports libraries?

JasperReports is updated quite frequently but the the JasperReports Integration toolkit is shipped with a specific version, originally 3.7.4. This is already quite outdated although the Integration toolkit didn't change it would still work against the latest JasperReports libraries. I have started to separate the libraries for the JasperReportsIntegration from the original JasperReports libraries, so now you can upgrade your installation by simply replacing the old libraries with the new ones.

  1. Stop the J2EE Server
  2. Remove the old JasperReports libraries. The removal scripts for each version are shipped with each release of the JasperReportsIntegration toolkit, but you can find them here as well:  https://www.opal-consulting.de/downloads/free_tools/JasperReportsLibraries/ :
    _jasper-reports-delete-libs-<version>.cmd and _jasper-reports-delete-libs-<version>.sh
  3. Download the new version (e.g. version 4.6.0 at https://www.opal-consulting.de/downloads/free_tools/JasperReportsLibraries/4.6.0/) and copy them into the directory [Tomcat directory]\webapps\JasperReportsIntegration\WEB-INF\lib\
  4. Start the J2EE server

Further questions will be added here as soon as they come up ;)